Improvement: When creating a machine key, modal can only be closed using the buttons to ensure user does not accidentally close modal and lose progress
Posted Apr 09, 2026 - 14:39 BST
Completed
An update to the machinekeys has been released
Posted Apr 09, 2026 - 14:24 BST
This scheduled maintenance affected: 🔗 SchemeServe API.